View Only

 I can't start Pentaho Server CE 9.1. Who can help me?

  • Pentaho
  • Pentaho
  • Pentaho Server
Angelo Augusto Frozza's profile image
Angelo Augusto Frozza posted 12-08-2020 22:14

I am setting up a development machine with Pentaho Server CE 9.1, Windows 10 and PostgreSQL 12.


I followed the Archive method for installation, according to the tutorial:


When I put in to start Pentaho (start-pentaho.bat), there are errors in the initialization (see attached files).


In the browser (localhost: 8080) I get this message:

"The following errors were detected[pt_49] One or more system listeners failed. These are set in the systemListeners.xml.   org.pentaho.platform.api.engine.PentahoSystemException: PentahoSystem.ERROR_0014 - [pt_71] Error while trying to execute startup sequence for"


Attached I put the two log files that present the error:

pentaho.log and karaf.log

Sergio Ribeiro's profile image
Sergio Ribeiro

Hello @Angelo Augusto Frozza​,


Try a different PostgreSQL version as version 12 is not (yet) supported:

Also check if you're using a supported Java version:




Sérgio Ribeiro

Porto - Portugal


Sylvain LE MAT's profile image
Sylvain LE MAT



@Angelo Augusto Frozza​ , have you solved your issue, please? I face the same issue ("One or more system listeners failed...") on a fresh installation (OS and Pentaho); I tried on Windows 10 and Linux Debian 10, with MySQL 8.0 and MS-SQL 2017, and with Java JRE 8, OpenJDK 8 and AdoptOpenJDK 8, and always have the same issue.


The only difference with you in the error message is that I get "Error while trying to execute startup sequence for {0}", which is not very helpful.


I'm considering installing the previous version, 9.0, which used to work on my side.


Thank you in advance.

Angelo Augusto Frozza's profile image
Angelo Augusto Frozza



Yes, I solved it.


I didn't use the tutorial.


I deleted the folder and unzipped a clean installation on \pentaho\server\pentaho-server.

So, I just ran the start-pentaho.bat file.


I had a problem with port 9001, but it was just stopping a windows service (Intel Graphics) that used this port.


I hope this helps you.

Sylvain LE MAT's profile image
Sylvain LE MAT

Hi Angelo,


Thank you for your message. I forgot to mention in my previous message that just after a clean installation, I could start Pentaho. But as soon as I wanted to use MS-SQL or MySQL for the repository, it was not working anymore.


I was doing 2 mistakes:

  • the first one, about the jackrabbit/repository.xml; I was correctly commenting out the sections for either mssql or mysql, but I was not commenting back the original uncommented sections for local files/local server; this one my first mistake, whatever database server I wanted to use;
  • the second one, not clear at all in the tutorial, for MySQL server, is that the bundled JDBC driver doesn't work. I replaced it by the MySQL Connector/J 8.0, which doesn't work too. This is clearly written in the tutorial though, but I didn't see it. In fact, we need the MySQL Connector/J 5.1.44 and over; I now use the version 5.1.49, the latest one. And I can perfectly connect to the MySQL server.


For the rest, I followed step by step the tutorial on


I hope this helps anybody who wants to use a MySQL or MS-SQL Server as repository database. I haven't tried with other DB servers.


Have a nice day.