• Kafka Consumer semantic in PDI 8.1

    Hi all I'm interested in setting up different semantics when retrieving data from Kafka with PDI: at most once, at least once, exactly once. I read [PDI-17272] Implement explicit commit in Kafka Consumer - Pentaho Pl...
  • Inconsistent data typing from the Database Lookup step between version 7.1 and 8.2

    We've run into a problem with inconsistent data typing from the Database Lookup step between version 7.1 and 8.2.   Using a postgresql database, any integer/bigint key lookup value typed to integer in the lookup...
    Smith Hutchings
    last modified by Smith Hutchings
  • something wrong with maven nexus repository

    I wanna integrate kettle in my java application with maven, but many dependencies in Repository - Nexus Repository Manager are unreachable and the nexus repository returns 500 status code.     I hope some...
    Wenxing Xu
    last modified by Wenxing Xu
  • Pentaho Community edition vs EE

    Hi All,   I wanted to know comparison between Pentaho Community edition and Enterprise edition? How can we get support for community edition from Pentaho team?
    Bharti Das
    last modified by Bharti Das
  • CSV file rearrange columns and export back to CSV file

    Hey There Newbie here, as of last week. I was just handed PDI 6.0.1 and was told to add additional functionality to a kettle job. Again, newbie, i didnt know what PDI or Kettle stood for or what it does. Im teaching ...
    Vincent Garcia
    last modified by Vincent Garcia
  • Join rows "startsWith" stop on first match - udjc?

    Dear Experts   We have a special data integration task to join "known hostnames" on given inputRows where hostname has many postfixes. example Stream1: server-abc        ...
    Thomas Lanz
    last modified by Thomas Lanz
  • how to set excel column width?

    Hi devs!   How can i set excel column width in Spoon? Auto size columns is not an option for me because of the contents, and i want to set the widths fix values. I wanted to set my columns width for example: A...
    Zoltan Rostas
    last modified by Zoltan Rostas
  • Is the Pentaho repository available from PDI CE without having Pentaho Server CE?

    I am using PDI 7.1 CE   I haven't been able to find documentation that explicitly addresses: 1) Can you access the Pentaho repository from PDI 7.1 without having Pentaho Server? and if you do need Pentaho Serv...
    Karen Fraser
    last modified by Karen Fraser
  • JDBC ORACLE - The Network Adapter could not establish the connection

    Hello     When i tried from my server rhel 7 to execute pan.sh command I have the following errors on my table Output: I have to copy the ojdbc8.jar file on the /home/pentaho/data-integration/lib   ...
    Herve Naga
    last modified by Herve Naga
  • I have installed Pentaho Community edition, Action->Schedule option is disabled in the Spoon.Can you please suggest how to enable it?

    I have installed Pentaho Community edition, Action->Schedule option is disabled in the Spoon. Can you please suggest how to enable it? Is there any plugin missing?
    Swati Dhawan
    last modified by Swati Dhawan
  • Excel Input Step Error Excel 2007 XLSX (Apache POI Streaming)

    I have a transformation that has been tested locally (Windows Environment) and runs successfully. When I promote to the repository and try to run from the Pentaho Server I receive errors about not being able open the ...
    Matthew Kennedy
    last modified by Matthew Kennedy
  • Providing a logic table for reporting tools

    Hello,   One of our case is to use a data source for BI tool, which data source should be provided on PDI.   Some of the data is on the Hadoop and a part on the DWH. If the data is on the Hadoop while th...
    Huriye Akbas
    created by Huriye Akbas
  • Hadoop Copy files is not working properly when triggering the job using Kitchen.bat/kitchen.sh

    Hi All,   I need a urgent help. As My project is completely in ig data environment and dealing with hive tables, I have used Hadoop copy files to place the file in HDFS system.   When i trigger the job dir...
    Shankar Panda
    last modified by Shankar Panda
  • How to use IAM role in S3 Output File Step

    I am trying to upload a file to S3 which requires AWS credentials and a specific role as well. The S3 Step fails with a 403:   Caused by: com.amazonaws.services.s3.model.AmazonS3Exception: Access Denied (Service...
    Serge Merzliakov
    last modified by Serge Merzliakov
  • SSH to access FTPS with Windows

    Hi,   I would like to connect to an ftp to download files to local and work with them, Due to security issues, I can access directly to FTP using GET a FILE with FTP, FTPS or SFTP. To avoid that we need to use ...
    Juanjo Castro
    last modified by Juanjo Castro
  • How to use metadata injection with Update step

    I'm using Pentaho Data Integration 8.2 CE and trying to use metadata injection to update data in table. For that I have created a transformation to get the metadata to inject, and a second transformation that contain...
    Ana Gonzalez
    created by Ana Gonzalez
  • AEL and Table Input Step?

    Hi all I am exploring Pentaho AEL features for a new assignment.I was able to read and process text files and hadoop input files using spark engine(AEL). But when we tried to run a job that is having oracle table as ...
    Jithin dev
    created by Jithin dev
  • Api Search console

    Hello, I'm trying to use the Search Console API with the client rest in PDI, but I can not. Do you have an example to provide me? Thank you in advance
    Yannis Murguet
    last modified by Yannis Murguet
  • Is there a way to use SQL Server Temp tables in the Transformation to generate a subset of data and use the output?

    I want to create a subset of my data into a SQL Server Temp table, I want a create a bunch of these temp tables and use them to generate an output which I can further use/transform and load to a SQL Server Table.
    Karan Mehta
    created by Karan Mehta
  • PDI Status SVG file not found

    HTTP ERROR: 404Problem accessing /pentaho/content/common-ui/resources/themes/images/run_options.svg. Reason: Not Found
    Kun Jiang
    last modified by Kun Jiang