Sam Walker

NSX Controller deployment failure - Timeout on waiting for controller ready

Blog Post created by Sam Walker on Sep 17, 2015

I have spent some time troubleshooting an issue with an NSX 6.2 Controller deployment and have arrived at maybe the simplest (but not something I have found documented anywhere) solution.

nsx trob.png

Through obvious troubleshooting (read the error, read the logs, read the KBs) I tried a lot of steps (which IMO are worth trying if you are faced with the same error yourself):

  • Ensure connectivity - run pings from the NSX manager to vCenter / Controller, etc.  Make sure your network is flat in the management cluster and you're not doing unnecessary routing.
  • Check the subnet mask is consistent all over.  This has caught others out.
  • There's a KB for clearing ARP cache on the physical switches (although this seems to be resolved from vCNS 5.something.
  • Checked the accounts I was using to register NSX in vCenter were correct...  Changed these, added permissions, etc...


The problem in the end - the password I was using was Passw0rd!"£$% (12345 with the shift key on a EN-GB keyboard pressed).  Another of the above steps was to avoid using special characters you'll only find on a EN-GB keyboard, so I tried Passw0rd!Passw0rd!....  Still no joy.


I tried changing it to a different string that was:


  • Above 12 characters
  • Had the requirements (upper, lower, special (I used !) and number
  • Didn't contain the word 'Passw0rd'

And it worked.  The password I changed it to was very similar to password in length and use of a 0 - but not password.....  And sure enough... I have managed to deploy the first controller (after 11 failed attempts!)