AnsweredAssumed Answered

G10 node to storage (direct connect) Multipath misconfiguration error

Question asked by Roguen (DevNet Admin) on Jan 2, 2017
Latest reply on Jan 2, 2017 by Roguen (DevNet Admin)

During the final phases of the ~/bin/install script from the highest numbered node…

 

Is this Configuration Correct?

[Default: no]: yes

 

You chose: "yes", is this correct?

[Default: yes]:

Verifying system name

Verifying run location

Verifying running as install

Verifying node connections

Verifying SSH keys

Verifying SSH

Verifying systemwide SSH

Verifying total memory > 32GB

Verifying all network links

Verifying HBA firmware

Verifying software versions

Verifying 64-bit hardware platform

Verifying drive size

Verifying disk space

Verifying nobody using /fcfs_*

Verifying nobody using /fs/*

Verifying volumes are spinning

Verifying standby volumes

Verifying multipath luns

Verifying multipath

10.1.1.116: Multipath is not configured correctly

 

…in a G10 with attached storage deployment (direct connect – no FC switches)… do we expect the cross-mapping of LUNs to explicitly be between contiguous node pairs in number order?

 

So:

Node01 + Node02

Node03 + Node04

Node05 + Node06

etc…

 

No doubt – that ordering of node pairing and related cross-mapping of LUNs is certainly what you get if you properly cable nodes to storage following the table in the guide – combined with the way the LUN mapping is done based on the storage config calculator:

 

Primary

Secondary

C0-P0A to N01-PRI

C1-P1A to N01-SEC

C0-P0B to N02-PRI

C1-P1B to N02-SEC

C0-P0C to N03-PRI

C1-P1C to N03-SEC

C0-P0D to N04-PRI

C1-P1D to N04-SEC

C0-P0E to N05-PRI

C1-P1E to N05-SEC

C0-P0F to N06-PRI

C1-P1F to N06-SEC

C0-P0G to N07-PRI

C1-P1G to N07-SEC

C0-P0H to N08-PRI

C1-P1H to N08-SEC


Or do we just try to find ~any pairs of nodes that have the same LUNs cross-mapped between them?

 

We have a new deployment – on which we will correct the cabling – where during the final steps of cluster installation, we get the error above during the ”Verifying multipath” step.

 

The multipathing of individual nodes is otherwise correct and LUN maps accurate (so primary/secondary connections of any single node is correct == servers primary FC port is connected to array ctl 0 port x, and servers secondary FC port is connected to array ctl 1 port x) like the table from the guide above calls for. But I’m wondering if (for instance) nodes 2 & 6 being connected to ports A & B on the array controllers (instead of nodes 1 and 2) would cause the error above – and if that activity should be better named something like “Verifying cross-mapping of luns” or some such.

Outcomes