AnsweredAssumed Answered

Enabling the HCI Search Service

Question asked by Roguen Keller Employee on Jan 10, 2017
Latest reply on Jan 10, 2017 by Roguen Keller

I'm going through the draft HCI setup guide on a fresh CentOS 7.2 vm.

 

On Step 6.8 of this guide I am enabling the service using systemd, but error out:

 

>sudo systemctl enable /opt/hci/bin/hci_search.service

The unit files have no [Install] section. They are not meant to be enabled

using systemctl.

Possible reasons for having this kind of units are:

1) A unit may be statically enabled by being symlinked from another unit's

   .wants/ or .requires/ directory.

2) A unit's purpose may be to act as a helper for some other unit which has

   a requirement dependency on it.

3) A unit may be started when needed via activation (socket, path, timer,

   D-Bus, udev, scripted systemctl call, ...).

I am able to successfully run example 1 in the foreground, but not enable in this way. What should I check?

Outcomes