AnsweredAssumed Answered

Reporting hourly data in Hitachi Tuning Manager

Question asked by Dave Blake on Sep 6, 2017

I am having a slight problem with performance reporter/HTnM running certain reports in my environment.  In most respects things are working ok and I can run most of the reports I need to.  However I have noticed I cannot report on hourly data for the subsystems connected to one agent server.  My environment is;

 

HTnM v8.5.1-00 running on server A

Raid agent v9.8 running on server B.  Contains a mix of G1Ks & VSPs.

Raid agent v9.6 running on server C.  Contains (other) G1Ks only.

 

I am using a test report HDS created for me to show some average pool stats, in performance reporter I am selecting the past 24 hours for the date range with a report interval of a minute or an hour.  On server C this works for all subsystems.  On server B this report works when I use a report interval of a minute, but when I change this to an hour I get an error;

 

"

KAVJS5001-I (PR2543)
MessageNo record was fetched. The report cannot be displayed.

"

 

Looking at the logs on server B I don't see any obvious errors but I do see one recurring message;

"1290 KAVE00213-W Collection of the performance data will be skipped because collection processing was delayed. (skipped time=2017/09/06 07:01:00, scheduled time=2017/09/06 07:02:00, record=PI_SCPS, type=historical)" (I see this for multiple records).  I do not see this message in the same log ("HiCommand\TuningManager\jp1pc\log\jpclog1.txt") on server C so it is the only noticeable difference between the two other than the agent version.  From conversations with some of my HDS colleagues they think that we collect the minute data which is then 'rolled-up'/averaged to give us the hourly figure... if this is correct (and it may well not be) then is there a process I need to look for that is creating the average hourly figure I need?

 

Can anyone help shed any light on it please, I am happy to post more info if it will help?

Outcomes