AnsweredAssumed Answered

build big_data_pugin error

Question asked by he wei on May 7, 2018

hi everyone

  when i try to bulid big-data-pugin(version:8.2.0.0-RC)

  In the end I got the following error

  My maven version is 3.5.2

  jdk version is jdk1.8.0_171

 

[INFO] pentaho-big-data-assemblies ........................ SUCCESS [  0.031 s]

[INFO] pentaho-big-data-plugin-osgi ....................... SUCCESS [  6.109 s]

[INFO] pentaho-big-data-plugin-samples .................... SUCCESS [  6.101 s]

[INFO] pentaho-big-data-assemblies-pmr-libraries .......... FAILURE [16:21 min]

[INFO] pentaho-big-data-plugin ............................ SKIPPED

[INFO] ------------------------------------------------------------------------

[INFO] BUILD FAILURE

[INFO] ------------------------------------------------------------------------

[INFO] Total time: 38:57 min

[INFO] Finished at: 2018-05-07T23:49:18+08:00

[INFO] Final Memory: 122M/538M

[INFO] ------------------------------------------------------------------------

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-assembly-plugin:3.1.0:single (assembly) on project pentaho-big-data-assemblies-pmr-libraries: Execution assembly of goal org.apache.maven.plugins:maven-assembly-plugin:3.1.0:single failed: For artifact {org.jvnet.staxex:stax-ex:null:jar}: The version cannot be empty. -> [Help 1]

[ERROR]

[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

[ERROR] Re-run Maven using the -X switch to enable full debug logging.

[ERROR]

[ERROR] For more information about the errors and possible solutions, please read the following articles:

[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginExecutionException

 

why single failed: For artifact {org.jvnet.staxex:stax-ex:null:jar}: The version cannot be empty.

how to fix that?

Outcomes