AnsweredAssumed Answered

Cannot set 'Null as' to empty string in 'Greenplum Load' step

Question asked by fei yuan on Jun 3, 2018

Hi, everyone, I'm trying to retrieve data from mongodb with 'MongoDB input' plugin and load the data to Greenplum with 'GreenPlum Load' plugin. The fields generated by MongoDB input step have with their own types such as 'Integer', 'Boolean', 'Date', ..., which is good for ddl SQL generation in 'Greenplum Load' step. However, since the generated fields are optional, there might be missing data, and the missing data for a field will be represented as an empty string in the gpload data file generated by 'Greenplum Load' step. I'd like to set the 'Null as' to an empty string which would load the null value for different types into GP, but this doesn't work in 'Greenplum Load' step, if I leave the 'Null as' blank in 'Greenplum Load' step, it will generate a gpload control file without 'NULL_AS' option, and this is certainly not what I want since gpload tool will use '\N' as default 'NULL_AS'. Is there any way for me to set empty string as 'Null as' in 'Greenplum Load' step?

Thanks!

Attachments

Outcomes