AnsweredAssumed Answered

Agent for SANSwitch - unable to start

Question asked by Christopher Senay on Jul 6, 2018
Latest reply on Jul 26, 2018 by Bhaskar Ramashankar

Tuning Manager agent for SAN switch, service fails to start.  Have set up instance as Cisco(DCNM-SAN SMI-S Agent), provided username/pw of admin user for DCNM, have also tried admin userid on seed switch, regardless seeing the following in log -

2018/07/05 15:54:37 jpcagtw  00033000 00016988 saC_SwitchAcces 0213 I Start the function (saC_SwitchAccessorDCNM::EstablishSession)

2018/07/05 15:54:37 jpcagtw  00033000 00016988 saC_CimData.cpp 0878 I Start the function (saC_CimData::CallEstablishSession)

2018/07/05 15:54:37 jpcagtw  00033000 00016988 saC_CimData.cpp 0992 I Call the java function(method=establishSession)

2018/07/05 15:54:37 jpcagtw  00033000 00016988 saC_CimData.cpp 0995 I IPAddress=xxx.xxx.xxx.xxx//cimv2,User=admin

2018/07/05 15:54:37 jpcagtw  00033000 00016988 saC_CimData.cpp 1013 I Return the java function(method=establishSession, detail1=xxx.xxx.xxx.xxx//cimv2, detail2=admin)

2018/07/05 15:54:37 jpcagtw  00033000 00016988 saC_CimData.cpp 1016 I Exit the function (saC_CimData::CallEstablishSession). (rc=0)

2018/07/05 15:54:37 jpcagtw  00033000 00016988 saC_CimData.cpp 0313 I Call the java function(method=enumerateInstances (P))

2018/07/05 15:55:19 jpcagtw  00033000 00016988 saC_JavaLibrary 0474 E Some unspecified error occurred in Java code. (method=enumerateInstance,line=1611, Detail : javax.wbem.WBEMException[CIM_ERR_FAILED]: Connection timed out: connect  [errno=10060, syscall=connect] - xxx.xxx.xxx.xxx:5988)

2018/07/05 15:55:19 jpcagtw  00033000 00016988 saC_CimData.cpp 0328 I Return the java function(method=enumerateInstances, detail1=CISCO_AdminDomain, detail2=0)

2018/07/05 15:55:19 jpcagtw  00033000 00016988 saC_SwitchAcces 0247 E A session with the proxy switch (or Fabric Management Server) cannot be established. (code=65825)

2018/07/05 15:55:19 jpcagtw  00033000 00016988 saC_SwitchAcces 0247 I Exit the function (saC_SwitchAccessorDCNM::EstablishSession). (rc=10005)

2018/07/05 15:55:19 jpcagtw  00033000 00016988 CAgent.cpp      1933 E KAVF25629-E A session with the DCNM-SAN SMI-S Agent could not be established. Exiting... (instance=440596, address=xxx.xxx.xxx.xxx, rc=0x10005, detail=65825)

 

Haven't seen much online about this.  One suggestion was that an advanced DCNM license was needed.  To me it seems to be a username/pw issue.  Has anyone set this up successfully and if yes, what are the details?

Thanks

Outcomes