AnsweredAssumed Answered

Pentaho PDI ETL : error connection to mysql version 8

Question asked by Paul Ristevs on Jul 20, 2018
Latest reply on Jul 25, 2018 by Chris Eicher

Hi,

 

I am using the latest distribution of MySQL and Pentaho PDI, but cannot connect in the test connection between PDI and MySQL. I put this on Stackoverflow as well.

 

Many people seem to have this issue.

My  friend had to use a mysql-jar file from year 2002 on MySQL version 5.5, in order to get the connection to work.

 

Hope someone is familiar with this issue:

 

One of the errors is this:

--> 'Unable to load authentication plugin 'caching_sha2_password'.

Outcomes