AnsweredAssumed Answered

how karaf loads big data plugins

Question asked by yang dong on Aug 30, 2018

I run kettle in idea.and add karaf to project path.it thorws the exception:

 

 

2018-08-30 16:29:48.222  INFO 2460 --- [  restartedMain] org.pentaho.platform.osgi.KarafBoot      : Checking to see if org.pentaho.clean.karaf.cache is enabled
2018-08-30 16:29:48.231 DEBUG 2460 --- [  restartedMain] o.ServerSocketBasedKarafInstanceResolver : Attempting to resolve available Karaf instance number by way of Server Socket
2018-08-30 16:29:48.232 DEBUG 2460 --- [  restartedMain] o.ServerSocketBasedKarafInstanceResolver : Instance test. Trying port 11001
2018-08-30 16:29:49.234 DEBUG 2460 --- [  restartedMain] o.ServerSocketBasedKarafInstanceResolver : Karaf instance resolved to: 1
2018-08-30 16:29:52.252  INFO 2460 --- [  restartedMain] org.pentaho.platform.osgi.KarafInstance  : 
*******************************************************************************
*** Karaf Instance Number: 1 at D:\ideaProjects\kettle\.\system\kar         ***
***   af\caches\kettleenvironment\data-1                                    ***
*** FastBin Provider Port:52901                                             ***
*** Karaf Port:8802                                                         ***
*** OSGI Service Port:9051                                                  ***
*******************************************************************************
Apache Karaf starting up. Press Enter to open the shell now...
2018-08-30 16:29:52.631  INFO 2460 --- [      Thread-38] org.apache.karaf.main.Main               : Lock acquired. Setting startlevel to 100
 19% [=============>                                                          ]2018-08-30 16:29:53.066  INFO 2460 --- [FelixStartLevel] o.a.karaf.service.guard.impl.Activator   : No role-based security for services as its system property is not set: karaf.secured.services
 32% [=======================>                                                ]2018-08-30 16:29:53.394  INFO 2460 --- [FelixStartLevel] o.a.a.b.c.BlueprintContainerImpl         : Bundle pentaho-webjars-deployer is waiting for namespace handlers [http://aries.apache.org/blueprint/xmlns/blueprint-cm/v1.1.0]
 45% [================================>                                       ]2018-08-30 16:30:01.438  INFO 2460 --- [      Thread-46] o.a.k.f.internal.FeaturesServiceImpl     : Installing feature pentaho-client-minimal 1.0
2018-08-30 16:30:01.438  INFO 2460 --- [      Thread-46] o.a.k.f.internal.FeaturesServiceImpl     : Installing feature pentaho-base 1.0
2018-08-30 16:30:01.438  INFO 2460 --- [      Thread-46] o.a.k.f.internal.FeaturesServiceImpl     : Installing feature pentaho-deployers 1.0
2018-08-30 16:30:01.438  INFO 2460 --- [FelixStartLevel] o.a.a.b.c.BlueprintContainerImpl         : Bundle org.apache.karaf.features.command is waiting for namespace handlers [http://karaf.apache.org/xmlns/shell/v1.1.0]
 47% [=================================>                                      ]2018-08-30 16:30:01.453  INFO 2460 --- [      Thread-46] o.a.k.f.internal.FeaturesServiceImpl     : Installing feature pentaho-webjars-deployer 7.1.0.0-12
2018-08-30 16:30:01.485  INFO 2460 --- [      Thread-46] o.a.k.f.internal.FeaturesServiceImpl     : Installing feature pentaho-cache-system 1.0
2018-08-30 16:30:01.485  INFO 2460 --- [      Thread-46] o.a.k.f.internal.FeaturesServiceImpl     : Installing feature transaction 1.1.1
2018-08-30 16:30:01.500  INFO 2460 --- [FelixStartLevel] .k.s.s.i.SecuredCommandConfigTransformer : Generating command ACL config org.apache.karaf.command.acl.scope_bundle into service ACL configs [org.apache.karaf.service.acl.command.scope_bundle.shell, org.apache.karaf.service.acl.command.scope_bundle.packages, org.apache.karaf.service.acl.command.scope_bundle.admin, org.apache.karaf.service.acl.command.scope_bundle.ssh, org.apache.karaf.service.acl.command.scope_bundle.osgi, org.apache.karaf.service.acl.command.scope_bundle.config, org.apache.karaf.service.acl.command.scope_bundle.jaas, org.apache.karaf.service.acl.command.scope_bundle.features, org.apache.karaf.service.acl.command.scope_bundle.log]
2018-08-30 16:30:01.601  INFO 2460 --- [FelixStartLevel] .k.s.s.i.SecuredCommandConfigTransformer : Generating command ACL config org.apache.karaf.command.acl.feature into service ACL configs [org.apache.karaf.service.acl.command.feature.uninstall, org.apache.karaf.service.acl.command.feature.install]
2018-08-30 16:30:01.617  INFO 2460 --- [      Thread-46] o.a.k.f.internal.FeaturesServiceImpl     : Installing feature pentaho-i18n 7.1.0.0-12
2018-08-30 16:30:01.633  INFO 2460 --- [FelixStartLevel] .k.s.s.i.SecuredCommandConfigTransformer : Generating command ACL config org.apache.karaf.command.acl.shell into service ACL configs [org.apache.karaf.service.acl.command.shell.java, org.apache.karaf.service.acl.command.shell.new, org.apache.karaf.service.acl.command.shell.edit, org.apache.karaf.service.acl.command.shell.exec]
2018-08-30 16:30:01.648  INFO 2460 --- [FelixStartLevel] .k.s.s.i.SecuredCommandConfigTransformer : Generating command ACL config org.apache.karaf.command.acl.system into service ACL configs [org.apache.karaf.service.acl.command.system.property, org.apache.karaf.service.acl.command.system.shutdown, org.apache.karaf.service.acl.command.system.start-level]
2018-08-30 16:30:01.679  INFO 2460 --- [FelixStartLevel] .k.s.s.i.SecuredCommandConfigTransformer : Generating command ACL config org.apache.karaf.command.acl.config into service ACL configs [org.apache.karaf.service.acl.command.config.property-append, org.apache.karaf.service.acl.command.config.property-delete, org.apache.karaf.service.acl.command.config.property-set, org.apache.karaf.service.acl.command.config.edit, org.apache.karaf.service.acl.command.config.update, org.apache.karaf.service.acl.command.config.cancel, org.apache.karaf.service.acl.command.config.delete]
2018-08-30 16:30:01.711  INFO 2460 --- [FelixStartLevel] .k.s.s.i.SecuredCommandConfigTransformer : Generating command ACL config org.apache.karaf.command.acl.jaas into service ACL configs [org.apache.karaf.service.acl.command.jaas.update]
2018-08-30 16:30:01.711  INFO 2460 --- [FelixStartLevel] .k.s.s.i.SecuredCommandConfigTransformer : Generating command ACL config org.apache.karaf.command.acl.bundle into service ACL configs [org.apache.karaf.service.acl.command.bundle.watch, org.apache.karaf.service.acl.command.bundle.update, org.apache.karaf.service.acl.command.bundle.install, org.apache.karaf.service.acl.command.bundle.uninstall, org.apache.karaf.service.acl.command.bundle.refresh, org.apache.karaf.service.acl.command.bundle.restart, org.apache.karaf.service.acl.command.bundle.stop, org.apache.karaf.service.acl.command.bundle.start]
2018-08-30 16:30:01.758  INFO 2460 --- [FelixStartLevel] .k.s.s.i.SecuredCommandConfigTransformer : Generating command ACL config org.apache.karaf.command.acl.kar into service ACL configs [org.apache.karaf.service.acl.command.kar.uninstall, org.apache.karaf.service.acl.command.kar.install]
 48% [==================================>                                     ]2018-08-30 16:30:01.789  INFO 2460 --- [FelixStartLevel] o.a.a.b.c.BlueprintContainerImpl         : Bundle org.apache.karaf.jaas.modules is waiting for namespace handlers [http://karaf.apache.org/xmlns/jaas/v1.0.0]
 61% [===========================================>                            ]2018-08-30 16:30:01.961  INFO 2460 --- [      Thread-46] o.a.k.f.internal.FeaturesServiceImpl     : Installing feature config 3.0.3
 69% [=================================================>                      ]2018-08-30 16:30:43.527  INFO 2460 --- [FelixStartLevel] o.a.a.b.c.BlueprintContainerImpl         : Bundle org.apache.aries.transaction.blueprint is waiting for dependencies [(objectClass=javax.transaction.TransactionManager)]
 86% [=============================================================>          ]ERROR: Bundle pentaho-blueprint-activators-7.1.0.0 [59] Error starting blueprint:mvn:pentaho/pentaho-blueprint-activators/7.1.0.0-12/xml/standard (org.osgi.framework.BundleException: Unresolved constraint in bundle pentaho-blueprint-activators-7.1.0.0 [59]: Unable to resolve 59.0: missing requirement [59.0] osgi.wiring.package; (osgi.wiring.package=org.pentaho.platform.osgi))
org.osgi.framework.BundleException: Unresolved constraint in bundle pentaho-blueprint-activators-7.1.0.0 [59]: Unable to resolve 59.0: missing requirement [59.0] osgi.wiring.package; (osgi.wiring.package=org.pentaho.platform.osgi)
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
at java.lang.Thread.run(Thread.java:748)
 89% [================================================================>       ]org.osgi.framework.BundleException: Unresolved constraint in bundle pentaho-osgi-utils-impl [62]: Unable to resolve 62.0: missing requirement [62.0] osgi.wiring.package; (&(osgi.wiring.package=org.pentaho.capabilities.api)(version>=7.1.0)(!(version>=8.0.0)))
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
at java.lang.Thread.run(Thread.java:748)
ERROR: Bundle pentaho-osgi-utils-impl [62] Error starting mvn:pentaho/pentaho-osgi-utils-impl/7.1.0.0-12 (org.osgi.framework.BundleException: Unresolved constraint in bundle pentaho-osgi-utils-impl [62]: Unable to resolve 62.0: missing requirement [62.0] osgi.wiring.package; (&(osgi.wiring.package=org.pentaho.capabilities.api)(version>=7.1.0)(!(version>=8.0.0))))
org.osgi.framework.BundleException: Unresolved constraint in bundle pentaho-mongodb-plugin [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (osgi.wiring.package=org.pentaho.di.core)
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
at java.lang.Thread.run(Thread.java:748)
org.osgi.framework.BundleException: Unresolved constraint in bundle meta-inject-plugin [66]: Unable to resolve 66.0: missing requirement [66.0] osgi.wiring.package; (osgi.wiring.package=org.pentaho.di.core)
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
at java.lang.Thread.run(Thread.java:748)
 91% [=================================================================>      ]ERROR: Bundle pentaho-mongodb-plugin [65] Error starting wrap:mvn:pentaho/pentaho-mongodb-plugin/7.1.0.0-12 (org.osgi.framework.BundleException: Unresolved constraint in bundle pentaho-mongodb-plugin [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (osgi.wiring.package=org.pentaho.di.core))
org.osgi.framework.BundleException: Unresolved constraint in bundle pdi-osgi-bridge-activator [68]: Unable to resolve 68.0: missing requirement [68.0] osgi.wiring.package; (&(osgi.wiring.package=org.pentaho.capabilities.api)(version>=7.1.0)(!(version>=8.0.0)))
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
ERROR: Bundle meta-inject-plugin [66] Error starting wrap:mvn:org.pentaho/meta-inject-plugin/7.1.0.0-12 (org.osgi.framework.BundleException: Unresolved constraint in bundle meta-inject-plugin [66]: Unable to resolve 66.0: missing requirement [66.0] osgi.wiring.package; (osgi.wiring.package=org.pentaho.di.core))
at java.lang.Thread.run(Thread.java:748)
 92% [==================================================================>     ]ERROR: Bundle pdi-osgi-bridge-activator [68] Error starting mvn:pentaho/pdi-osgi-bridge-activator/7.1.0.0-12 (org.osgi.framework.BundleException: Unresolved constraint in bundle pdi-osgi-bridge-activator [68]: Unable to resolve 68.0: missing requirement [68.0] osgi.wiring.package; (&(osgi.wiring.package=org.pentaho.capabilities.api)(version>=7.1.0)(!(version>=8.0.0))))
100% [========================================================================]
Karaf started in 51s. Bundle stats: 63 active, 68 total
2018-08-30 16:31:33.625 ERROR 2460 --- [ Timeout Thread] o.p.di.osgi.KarafLifecycleListener       : The Kettle Karaf Lifecycle Listener failed to execute properly after waiting for 100 seconds. Releasing lifecycle hold, but some services may be unavailable.
2018/08/30 16:31:33 - General - Plugin KettleXmlPlugin does not implement GUIOption, it will not be editable

Outcomes