AnsweredAssumed Answered

Table Input Step not returning the same number of previewed records

Question asked by B167W1XV on Nov 14, 2018
Latest reply on Nov 15, 2018 by Dan Keeley

I'm working on a Transformation which selects from an Oracle database, inserts into a mapping table, performs a couple of lookups and mappings, then inserts into an PostgreSQL database. When I tested with a handful of mocked up records, it worked as expected.

 

Now I'm running against a Test data set. When I preview the Oracle table input (select) step, it returns the expected number of records (1,151).

 

When I run the transformation, it fails. The error according to the Step Metrics is on the PostgreSQL Insert/Update step.

 

However, when examining the Step Metrics, the Oracle select step has only retrieved 51 records.

 

Can anybody explain this behavior? At a minimum, I would expect the Input of the Oracle select step to show an Input of 1,151 since the number in the Previewing is correct.

 

Thanks in advance!

Outcomes