AnsweredAssumed Answered

PMI Deep Learning network step - The following engines are unavailable (check configuration): Python - Scikit-learn R - MLR Spark - MLlib DL4j

Question asked by Ingo Levin on Nov 16, 2018
Latest reply on Nov 19, 2018 by Ingo Levin

Having upgrade to the latest PMI 1.4 from Marketplace, I am getting the following error message opening the PMI Deep Learning network step:

"The following engines are unavailable (check configuration): Python - Scikit-learn R - MLR Spark - MLlib DL4j "

 

This only happens on the Deep Learning step, the other PMI steps work fine. I suspect it is not installing/loading the DJ4j lib correctly.

 

 

On the console

java.lang.ClassNotFoundException: weka.python.PythonSession

        at java.net.URLClassLoader.findClass(Unknown Source)

        at java.lang.ClassLoader.loadClass(Unknown Source)

        at java.lang.ClassLoader.loadClass(Unknown Source)

        at org.pentaho.di.core.plugins.KettleURLClassLoader.loadClassFromParent(

KettleURLClassLoader.java:94)

        at org.pentaho.di.core.plugins.KettleURLClassLoader.loadClass(KettleURLC

lassLoader.java:114)

        at java.lang.ClassLoader.loadClass(Unknown Source)

        at java.lang.Class.forName0(Native Method)

        at java.lang.Class.forName(Unknown Source)

        at weka.core.WekaPackageClassLoaderManager.forName(WekaPackageClassLoade

rManager.java:206)

        at weka.core.WekaPackageClassLoaderManager.forName(WekaPackageClassLoade

rManager.java:186)

        at org.pentaho.pmi.engines.PythonEngine.<clinit>(PythonEngine.java:58)

        at org.pentaho.pmi.PMIEngine.init(PMIEngine.java:86)

        at org.pentaho.pmi.PMIEngine.getEngineNames(PMIEngine.java:100)

        at org.pentaho.di.ui.trans.steps.pmi.BaseSupervisedPMIStepDialog.addConf

igTab(BaseSupervisedPMIStepDialog.java:719)

        at org.pentaho.di.ui.trans.steps.pmi.BaseSupervisedPMIStepDialog.open(Ba

seSupervisedPMIStepDialog.java:358)

        at org.pentaho.di.ui.spoon.delegates.SpoonStepsDelegate.editStep(SpoonSt

epsDelegate.java:120)

        at org.pentaho.di.ui.spoon.Spoon.editStep(Spoon.java:8949)

 

Tried these troubleshooting steps:

1) remove the ~\wekafiles directory

 

2) Re-Installed all R packages. Now have

> packageVersion('JavaGD')

[1] ‘0.6.1’

> packageVersion('XML')

[1] ‘3.98.1.9’

> packageVersion('LiblineaR')

[1] ‘2.10.8’

> packageVersion('e1071')

[1] ‘1.6.8’

> packageVersion('randomForest')

[1] ‘4.6.12’

> packageVersion('nnet')

[1] ‘7.3.12’

> packageVersion('gbm')

[1] ‘2.1.3’

 

3) Ran pyCheck.py. No errors.

C:\Users\ingo>python wekafiles/packages/wekaPython/resources/py/pyCheck.py

 

C:\Users\ingo>

 

4) Started Spoon. Having removed the wekafiles folder earlier, it forced a fresh download of all the packages.

 

5) Restarted Spoon. Created new Transformation and added the Deep Learning step:

Still getting the same error when I attempt to open the step.

Outcomes