AnsweredAssumed Answered

Upgrading custom plugin from 4.4 to 8.1 - error - Unable to find class loader for plugin

Question asked by John Heath on Dec 17, 2018
Latest reply on Jan 8, 2019 by Brandon Jackson

I apologize in advance as I am not a Java developer. I am getting the following error for our custom MQ step plugin: Unable to find class loader for plugin: VericalWebsphereMQConsumer/Websphere MQ Consumer{class org.pentaho.di.core.plugins.StepPluginType}

 

This plugin works fine in the 4.4 environment. I have complied the plugin successfully in the 8.1 environment. I am using Ant to compile and install the plugin. It is installing the JAR to data-integration/plugins/.

 

Any ideas on why I am getting this error? Am I missing a dependancy?

Outcomes