Legacy HDS Forums

HDLM on RHEL 4u4 kernel-2.6.9-42 bad problem...

Discussion created by Legacy HDS Forums on Jan 31, 2007

Originally posted by: sruby8



when you run installhdlm on a system that is 64bit Opteron hardware and installed with 32bit RHEL 4 (this is done because of application compat issues), the install balks with the following error:

[root@localhost cdrom]# uname -a
Linux localhost.localdomain 2.6.9-42.0.2.EL #1 Thu Aug 17 17:36:53 EDT 2006 i686 i686 i386 GNU/Linux
[root@localhost cdrom]# cat /etc/redhat-release
Red Hat Enterprise Linux WS release 4 (Nahant Update 3)
[root@localhost cdrom]# ./installhdlm
KAPL09160-E HDLM does not support this kernel.
[root@localhost cdrom]# pwd
/media/cdrom
[root@localhost cdrom]# cd rpm
[root@localhost rpm]# rpm -ivh --force HDLM-5.81.0.470-9.i386.rpm
Preparing...                ########################################### [100%]
KAPL09003-E Cannot install in this system.
error: %pre(HDLM-5.81.0.470-9.i386) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping HDLM-5.81.0.470-9

i even tried manually installing the x64 rpms and that obviously wouldnt work because none of the 64bit libs are installed. also the kernel isnt x64 so you cant even install the 64bit libs (glibc, etc).

a case was opened with Sun support (Storage and HDLM was bought through Sun) and they claimed its a known issue with no resolution or workaround.

Can someone in HDLM engineer verify this and help me out with a fix?

thanks
sr

Outcomes