AnsweredAssumed Answered

Problem to setup Shadow Image replication for SRM on HUS100

Question asked by Marco Bakker on Jun 25, 2014
Latest reply on Jun 4, 2015 by Brian Blake

Hi,

 

For a customer we are setting up SRM for their VMware envirionment which is build on HUS130 (production site) and HUS110 on DR site. We are using TrueCopy Extended (async) for the replication of the ESX datastore LUNs. On the two vCenter servers we have installed CCI Raid manager en configured HORCM instances.

HORCM instances:

HORCM100 = vcenter1, storage is HUS130 and volumes are PVOLs for TCE,

HORCM101 = vcenter2, storage is HUS110 and volumes are SVOLs for TCE,

HORCM102 = vcenter2, storage is HUS110 and configured for SI, the SVOL from the TCE will be used as the PVOL for SI.

 

The problem is that we can not set up the SI with the SVOL from the TCE, we want to use them as the PVOL for the SI local replication. From the "Hitachi SRA 2.0 for VMware vCenter SRM 5.0/5.1 Deployment guide" we found the commands but it looks like they are different for our environment.

 

The command will fail, wrong arguments:

 

paircreate -g SIGoes1 -vl -m grp -fq quick –ISI101

paircreate: requires '-m  cyl or trk' as argument
paircreate: requires '-f <never/status/data/async>' as argument
paircreate: [EX_INVARG] Invalid argument
Refer to the command log(C:\HORCM\log\horcc_SRV-VCS-002_log.txt) for details.


When I check with the -h option I do not see the -m grp option (only cyl or trk) and with -f we can choose never/status/data/async and not "quick"?

We can see them in the Simplex status:

 

c:\HORCM\etc>pairdisplay -g SIGoes1 -fxme -ISI101

Group   PairVol(L/R) (Port#,TID, LU-M) ,Seq#,LDEV#.P/S,Status, Seq#,P-LDEV# M CTG CM EM       E-Seq# E-LDEV#

SIGoes1 SI_LU1101_LU1151(L) (CL1-E-3, 1, 101-0 )91256799   44d.SMPL  ----,-----   ----- -   -  - - -       -

SIGoes1 SI_LU1101_LU1151(R) (CL1-E-3, 1, 151-0 )91256799   47f.SMPL  ----,-----   ----- -   -  - - -       -

SIGoes1 SI_LU1102_LU1152(L) (CL1-E-3, 1, 102-0 )91256799   44e.SMPL  ----,-----   ----- -   -  - - -       -

SIGoes1 SI_LU1102_LU1152(R) (CL1-E-3, 1, 152-0 )91256799   480.SMPL  ----,-----   ----- -   -  - - -       -

SIGoes1 SI_LU1103_LU1153(L) (CL1-E-3, 1, 103-0 )91256799   44f.SMPL  ----,-----   ----- -   -  -  - - -

SIGoes1 SI_LU1103_LU1153(R) (CL1-E-3, 1, 153-0 )91256799   481.SMPL  ----,-----   ----- -   -  - - -       -

SIGoes1 SI_LU1104_LU1154(L) (CL1-E-3, 1, 104-0 )91256799   450.SMPL  ----,-----   ----- -   -  - - -       -

SIGoes1 SI_LU1104_LU1154(R) (CL1-E-3, 1, 154-0 )91256799   482.SMPL  ----,-----   ----- -   -  - - -       -

 

c:\HORCM\etc>pairdisplay -g SIGoes2 -fxme -ISI101

Group   PairVol(L/R) (Port#,TID, LU-M) ,Seq#,LDEV#.P/S,Status, Seq#,P-LDEV# M CTG CM EM       E-Seq# E-LDEV#

SIGoes2 SI_LU1105_LU1155(L) (CL1-E-3, 1, 105-0 )91256799   451.SMPL  ----,-----   ----- -   -  - - -       -

SIGoes2 SI_LU1105_LU1155(R) (CL1-E-3, 1, 155-0 )91256799   483.SMPL  ----,-----   ----- -   -  -  - - -

SIGoes2 SI_LU1106_LU1156(L) (CL1-E-3, 1, 106-0 )91256799   452.SMPL  ----,-----   ----- -   -  - - -       -

SIGoes2 SI_LU1106_LU1156(R) (CL1-E-3, 1, 156-0 )91256799   484.SMPL  ----,-----   ----- -   -  - - -       -

 

c:\HORCM\etc>pairdisplay -g SIGoes3 -fxme -ISI101

Group   PairVol(L/R) (Port#,TID, LU-M) ,Seq#,LDEV#.P/S,Status, Seq#,P-LDEV# M CTG CM EM       E-Seq# E-LDEV#

SIGoes3 SI_LU1107_LU1157(L) (CL1-E-3, 1, 107-0 )91256799   453.SMPL  ----,-----   ----- -   -  - - -       -

SIGoes3 SI_LU1107_LU1157(R) (CL1-E-3, 1, 157-0 )91256799   485.SMPL  ----,-----   ----- -   -  - - -       -

 

Is there somebody who has experience with setting this up? Is it possible on HUS systems? We do have the licenses enabled for SI, CoW and TCE on both systems.

 

We need the SI for testing SRA and do not want to split the TCE replication.

 

Thanks!

Attachments

Outcomes