AnsweredAssumed Answered

dm multipath and a HUS110

Question asked by Jason Berendsen on Aug 21, 2014
Latest reply on Aug 21, 2014 by Jason Berendsen

I have a Centos 6.3 server that I have connected to a HUS110 with dual connections.  At first I had just the default multipath.conf setup which resulted in this when doing a multipath -ll:

mpathah (360060e8010000093) dm-41 HITACHI,DF600F
size=1.0T features='1 queue_if_no_path' hwhandler='0' wp=rw
|-+- policy='round-robin 0' prio=1 status=active
| `- 2:0:2:0  sdbp 68:48  active ready running
`-+- policy='round-robin 0' prio=0 status=enabled
  `- 1:0:2:0  sdbo 68:32  active ready running

 

When doing an iostat I see IO down one path

 

I see the config for a Hitachi array in /usr/share/doc/device-mapper-multipath-0.4.9/multipath.conf.defaults:

#device {
#               vendor "HITACHI"
#               product "OPEN-.*"
#               path_grouping_policy multibus
#               getuid_callout "/lib/udev/scsi_id --whitelisted --device=/dev/%n"
#               path_selector "round-robin 0"
#               path_checker tur
#               features "0"
#               hardware_handler "0"
#               prio const
#               rr_weight uniformug 21 12:27:01 | multipath.conf line 36, invalid keyword: path_grouping_policy

#               no_path_retry 6
#               rr_min_io 1000
#               rr_min_io_rq 1
#       }

 

When I bring this into /etc/multipath.conf and do a multipath I get the following errors:

Aug 21 12:27:01 | multipath.conf line 36, invalid keyword: path_grouping_policy
Aug 21 12:27:01 | multipath.conf line 37, invalid keyword: getuid_callout

Aug 21 12:27:01 | multipath.conf line 38, invalid keyword: path_selector

Aug 21 12:27:01 | multipath.conf line 39, invalid keyword: path_checker

Aug 21 12:27:01 | multipath.conf line 40, invalid keyword: features

Aug 21 12:27:01 | multipath.conf line 41, invalid keyword: hardware_handler

Aug 21 12:27:01 | multipath.conf line 42, invalid keyword: prio

Aug 21 12:27:01 | multipath.conf line 43, invalid keyword: rr_weight

Aug 21 12:27:01 | multipath.conf line 44, invalid keyword: no_path_retry

Aug 21 12:27:01 | multipath.conf line 45, invalid keyword: rr_min_io

Aug 21 12:27:01 | multipath.conf line 46, invalid keyword: rr_min_io_rq

 

Any idea what is wrong with this config?

Outcomes