AnsweredAssumed Answered

smu serice cannot be enabled

Question asked by Artur Kolarik on May 16, 2015
Latest reply on May 17, 2015 by Dang Luong


Hello all,

 

I have a problem to enable smu service on HNAS machine. Let me explain, how it happened.

 

I upgraded OS version on the single node cluster with embedded SMU from nas-12.2.3719.07.tar to nas-12.3.3826.03a.tar. Software versions should be compatible.

 

Once I uploaded the right package to the cluster via SMU GUI, the new OS version was installed. The problem occurred when I logged to the GUI after upgrade. The error message stated that SMU version was not compatible with the new OS version. As a result of it API functionality was not working properly.

 

Therefore I restarted smu service several times without any effect. The next step to be taken was disabling and then enabling smu service.

 

Disabling went fine, but enabling is a problem now due to lack of memory:

 

testhc01-adm:$ smu-service-enable
Refusing to apply modifications; insufficient resource available.
Could not enable embedded SMU. Not enough uncommitted memory is available. See resource-config-test to adjust system resources.
testhc01-adm:$ resource-config-test

                Memory      Current
----------------------     --------
       System overhead     1.598 GB
             Bali heap     5.694 GB
         Deduplication            -
Data Migrator to Cloud       [auto]
          Embedded SMU            -

       Total available         8 GB
       Total committed     7.292 GB

    Uncommitted memory       725 MB

NOTE: No modifications specified. Displaying current configuration.

 

I tried to do following to solve the issue, but nothing helped:

 

1. Reverting OS version back to nas-12.2.3719.07.tar. I did it by setting the default package value to 12.2.3719.07.tar and subsequent reboot.

 

Current version after revert:

Model: 3080

Software: 12.2.3719.07 (built 2014-12-03 01:03:23+00:00)

 

2. I removed the new package nas-12.3.3826.03a.tar from the system and rebooted.

 

I see still the same problem... Not enough uncommitted memory...

 

 

I'd appreciated two pieces of advice:

 

A. What should I do to re-enable embedded SMU?

 

B. Is it possible not only to upgrade OS version to nas-12.3.3826.03a.tar, but also SMU version? I must have skipped something during upgrade process, but I do not know what.

 

 

Thank you in advance for any hint.

 

 

 

Outcomes