View Only

 Pentaho DI - Java Platform SE binary is not responding

  • Pentaho
  • Pentaho
  • Pentaho Data Integration PDI
Jurijs Tomashun's profile image
Jurijs Tomashun posted 09-30-2021 12:49

Hoping if anyone could help with such issue.

I wanted to use pentaho, but that pentaho is not opening (spoon.bat) - it's freezing after main UI is loaded - and I cannot do anything - connect to repo, tool just freezes and then crashes with mentioned in header error. intersting, that this happened also at work server (through remote desktop) - so in both machines - my private (version 8.3) and work server (version 9.0) stopped working. Interesting, that on work server version 7.0 continues to work as usual. Problem starts when using version 7.1+, then this error happens.


 had all necessary system variables (well previously pentaho was working without any issues).

What I did currently:

1)I tried to install openJDK, AdoptDJK, oracle JDK 8 (and switching JAVA_HOME) , but none of these helped - same "stopped working".

2) I tried to reinstall whole java (uninstalled,rebooted etc.) - nothing helped

3) played with variables - was reading on other forums to add other system variables - used different, _JAVA_OPTIONS etc. - nothing helped

4) downloaded different versions of pentaho - same freeze.

5) checked graphic card updates - everything is set as latest

6) was changing different parameters in spoon.bat (like memory etc.), no result.

7) cleaned Java cache

8) cleaned pentaho cache...


I have a feeling that there is or some app blocking Pentaho or some corporate driver updates happened that for some reason affected usage of Java Platform...

What I'm missing? What is different between version 7.0 and 7.1/8.3/9.0/9.2?

screenshot of error

Jurijs Tomashun's profile image
Jurijs Tomashun

So, after investigation, found a solution - problem wasn't in java or pentaho as such, issue was in Microsoft security update. Basically this solves issue:


if someone will face it, try this fix, helps.