View Only

 Error when trying to change a Tranformation step's settings in a job in PDI 9 community edition

  • Pentaho
  • Kettle
  • Pentaho
  • Pentaho Data Integration PDI
Stefan H.'s profile image
Stefan H. posted 09-16-2020 08:17

I downloaded PDI Community Edition 9.


If I open a job in (from Windows filesystem) it, try to change the transformation details and click "OK", I get "Error editing job entry". If I discard the error requester and click okay again I get "An unexpected error occurred in Spoon: null" with the stacktrace below.

If I again click "OK" I get "Your PDI client has encountered an error and may not be stable".


In PDI 8.2 everything works fine.


Thanks for insights in advance.

java.lang.NullPointerExceptionat org.pentaho.di.engine.configuration.impl.extension.RunConfigurationSaveExtensionPoint.embedRunConfigurations( org.pentaho.di.engine.configuration.impl.extension.RunConfigurationSaveExtensionPoint.callExtensionPoint( org.pentaho.di.core.extension.ExtensionPointMap.callExtensionPoint( org.pentaho.di.core.extension.ExtensionPointHandler.callExtensionPoint( org.pentaho.di.ui.job.entries.trans.JobEntryTransDialog.getInfo( org.pentaho.di.ui.job.entries.trans.JobEntryTransDialog.ok( org.pentaho.di.ui.job.entries.trans.JobEntryBaseDialog$6.handleEvent( org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)at org.eclipse.swt.widgets.Display.sendEvent(Unknown Source)at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)at org.eclipse.swt.widgets.Display.runDeferredEvents(Unknown Source)at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)at org.pentaho.di.ui.spoon.Spoon.readAndDispatch( org.pentaho.di.ui.spoon.Spoon.waitForDispose( org.pentaho.di.ui.spoon.Spoon.start( org.pentaho.di.ui.spoon.Spoon.main( sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)at java.lang.reflect.Method.invoke(Unknown Source)at org.pentaho.commons.launcher.Launcher.main(


Marko Schleicher's profile image
Marko Schleicher

Hi @ All,


we upgraded our PDI. We got an older version (V5.4) for productive jobs. Now we installed a newer Version (V9) and import some jobs from the older version.

IN some jobs we reference in a job to a transformation. with this transformaiton we read some specific directory, to get the name of the files and after this we want to change the names of files in the directory.


In V5.4 we get with this tranformations the names of the files without error.

The step "Filter rows" take the name of the file and put it back to the step "Set files in result":

In V9 we get the following Error Message:

2020/09/18 08:42:16 - Filter rows.0 - ERROR (version, build from 2020-01-31 04.53.04 by buildguy) : Unexpected error

2020/09/18 08:42:16 - Filter rows.0 - ERROR (version, build from 2020-01-31 04.53.04 by buildguy) : org.pentaho.di.core.exception.KettleException:

2020/09/18 08:42:16 - Filter rows.0 - Step [Set files in result] is invalid as target.

2020/09/18 08:42:16 - Filter rows.0 -

2020/09/18 08:42:16 - Filter rows.0 -   at org.pentaho.di.trans.steps.filterrows.FilterRows.processRow(

2020/09/18 08:42:16 - Filter rows.0 -   at

2020/09/18 08:42:16 - Filter rows.0 -   at Source)


Someone got an idea, why the transformation running in V5.4 and not in V9?


Best Regards,



Stefan H.'s profile image
Stefan H.

You should have opened a new question instead of hijacking mine.


But looking around here it looks like these questions are never answered by anyone. The community version support completely vanished since Hitachi took over. I guess they want so sell the business edition. So regarding these problems we are most probably on our own. This does not encourrage me to subscribe to the business edition.


I guess there is still the option to open an issue in Jira ...

Johan Hammink's profile image
Johan Hammink

I got the same error in version 9.0. But in version 9.1 all works as expected. So I guess they solved the problem

Stefan H.'s profile image
Stefan H.



If I try this in PDI 9.1 CE it takes a very long time to open a transformation from a job, over two minutes ... It looks to me as if there are still things wrong with this. I am still not confident using 9.x


We were discussing changing to the business edition, but after the nonsupport shown here, we will most probably choose another solution.