View Only

 JSON Input is not working with Open JDK15

  • Pentaho
  • Pentaho
Andreas Enocson's profile image
Andreas Enocson posted 02-03-2021 08:18

We are trying to use OpenJDK 15 with BMC Product(using Pentaho 6.0 ) but JSON Input step is not working with Open JDK15 as Nshorn has been removed from this version.

We tried downloading the nashorn jar file from maven site and placed it in 3 different paths:

C:\Program Files\Java\jdk-15.0.1\bin

C:\Program Files\Java\jdk-15.0.1\lib

D:\Program Files\BMC Software\ARSystem\diserver\data-integration\lib

Restarted the spoon multiple times as well as the whole server.

Still the JSON Input is not working and throwing nashorn error.

We also tried a method mentioned in:

Still it didn't

Sergio Ribeiro's profile image
Sergio Ribeiro

Hello @Andreas Enocson​,


Pentaho 6.0 (released in 2015, if I'm not mistaken) required Oracle Java 6/7.

Even 9.1, the most recent version, only supports Java 8 (Oracle or OpenJDK).


I think it will be very difficult to use that configuration.




Sérgio Ribeiro

Porto - Portugal.