Pentaho

 View Only
  • 1.  PDI CE 9.4: updating MongoDB java driver to more recent versions

    Posted 05-04-2023 04:41

    Hello everyone,
      I have seen that the MongoDB Input/Output steps in PDI CE 9.4 use the mongodb plugin pentaho-mongodb-plugin-9.4.0.0-343 which in its turns it's using the mongo-java-driver-3.12.10. This driver is quite old and is based on the legacy API. Simply replacing the mongo-dava-driver-3.12.10.jar with a newer  release (4.4 and above) is not working because it seems to me that some code must be migrated.

    Do you know if there is a quick option (plug and play) to update the Mongo java driver? If not, which are the steps to go through in order to migrate the pentaho-mongodb-plugin such that it is compatible with the newer mongodb java driver?

    Thank you



    ------------------------------
    Antonio Petrella
    Data Service Manager
    UNOG
    ------------------------------


  • 2.  RE: PDI CE 9.4: updating MongoDB java driver to more recent versions

    Posted 11-08-2023 09:29

    Hello, any help?



    ------------------------------
    Antonio Petrella
    Data Service Manager
    UNOG
    ------------------------------



  • 3.  RE: PDI CE 9.4: updating MongoDB java driver to more recent versions

    Posted 11-21-2023 16:31

    Hello,

    Pentaho 9.4 is compatible with MongoDB 4.4. See our component reference page.

    If still cannot overcome your problem please contact our experts and present them with your use-case and configurations. 



    ------------------------------
    Mladen Milev
    Software Development Engineering Senior Manager
    Hitachi Vantara
    ------------------------------



  • 4.  RE: PDI CE 9.4: updating MongoDB java driver to more recent versions

    Posted 11-22-2023 03:03

    Hello, 

       thank you for your reply. The problem is not the compatibility of PDI 9.4 CE with MongoDB server itself.  The question is related to the upgrade of the mongodb java driver that is wrapped in the pentaho mongodb plugin. Currently this plugin wraps mongodb java driver version 3.12 that implements the old MongoDB API.

    Thanks, 



    ------------------------------
    Antonio Petrella
    Data Service Manager
    UNOG
    ------------------------------