View Only

 Data containing Date not moving correctly using Pentaho Kettle!

ali rana's profile image
ali rana posted 05-18-2023 21:43

We are moving data between Sybase and MS SQL Server. We have a table which has a date column defined as Date sample "2015-03-15" on source as well as target DB. When we use Spoon to extract and load into MS SQL Server the data value moves correctly. When we try to use a simple krt file with kettle via. spring boot application we notice -1 day in the date value. So the new value which shows up with kettle is 2015-03-14. We have tried to trouble shoot transaction and look at various debug logs however we are not sure why Pentaho kettle is modifying this value. Any help or insight is greatly appreciated. 


Petr Prochazka's profile image
Petr Prochazka

Hi Ali,
this looks like problem with time zone. Kettle internally use java.util.Date for DATE datatype. Are you running on same machine?
Or check this variable KETTLE_COMPATIBILITY_DB_IGNORE_TIMEZONE is not set to Y/true in your app.

ali rana's profile image
ali rana

Thank you Petr for the answer. we tried providing that argument in Meta with different combinations like 

We have even set the system time in spring boot container during startup to Central Time but we have not been able to fix this issue. We are using kettle core, mondarain and made sure we are using the 9.3 -428 version. Even tried to downgrade to 8.3 but this is one of the few issues we have not been able to find a resolution for till now.