• Error (Access Denied)

    Hey everyone. I am getting an error in a job I set up a few months ago and I can't seem to solve it. Here is the video (it's attached to the post) for more information if that is more helpful for you; basically, the p...
    Nathan Mahler
    created by Nathan Mahler
  • Kafka Consumer semantic in PDI 8.1

    Hi all I'm interested in setting up different semantics when retrieving data from Kafka with PDI: at most once, at least once, exactly once. I read [PDI-17272] Implement explicit commit in Kafka Consumer - Pentaho Pl...
    Virgilio Pierini
    last modified by Virgilio Pierini
  • Spark AEL Engine

    Hi Team,   I need some clarification regarding spark AEL engine which I am using to execute .ktr(transformation) through Web-Spoon.   Basically only a .ktr(transformation) can be executed through spark. I ...
  • PMI plugin Python error

    I have recently downloaded the PMI plugin and struggling running the examples, specifically build-model.ktr. I keep on getting error on the Gradient Booster (Python) node. I have uninstalled and re-installed both Pyth...
    Marilyn Singh
    last modified by Marilyn Singh
  • How to abort streaming Kafka Consumer

    Pentaho Data Integration CE I'm using the Kafka Consumer step in PDI v8.2. Since this step runs continuously, documentation suggests using an Abort step to stop the process periodically. I'm looking for some suggestio...
    Brad Gatewood
    last modified by Brad Gatewood
  • Clarification on XSD Validator Step

    Hi Team, Issue with xsd validator step in PDI version 8.2. -> xsd validator step is not taking hdfs location as input for xsd,when we pass hdfs location as input it is automatically taking local path of tomcat ...
  • Variable passing in switch case

    I m new to pentaho,I m reading a text file and it has record which contain header as date and file name. FIle format is something as H22042019EMP asalsakslaks asasasasas   header is 22042019EMP and then de...
    Pradeep Jha
    last modified by Pradeep Jha
  • Unable to find table name field[null] in input row

    I am working on the below and running into the error - Unable to find table name field[null] in input row. Please assist   https://help.pentaho.com/Documentation/8.2/Setup/Evaluation/Tutorials/0C0/020
    archana garikapati
    last modified by archana garikapati
  • Is it possible to extract data from multiple table and load different tables in one transformation.

    Hi, Is it possible to extract data from multiple table and load different tables in one transformation. i.e Table A , Table B, Table C from Source A (Oracle DB) and load into Table X, Table Y & Table Z into Sourc...
  • How to create a nested XML Output

    How can I create a nested XML output that takes multiple sets of data and combines them into a single nested XML output?   I've tried multiple different steps with the XML joins, streams, merges, etc, and no...
    Mike Spiegel
    last modified by Mike Spiegel
  • Keeping large tables in sync

    Hi community,   I'm trying to keep a large table ( > 60M rows) from a local Oracle database in sync with an Azure SQL database. I'm aware of the "Insert/ update" operator, and my current transformation looks ...
    Gert Wieland
    last modified by Gert Wieland
  • How access youtube API data with PDI?

    Hi, im trying to access the youtube API data from our youtube channel with pentaho data integration but i have no idea how i can acces it.   I tried with javascript step for example but didnt work.    ...
    Augusto Santos
    last modified by Augusto Santos
  • Unable to use CSV Input with file on a UNC (network path)

    I'm using Data Integration 8.1 on Windows, and using CSV Input I have the CSV on a network drive - \\DevServer\Dev\test.csv for example.  When I create the CSV File and put the path in Filename I click Get Fields...
    Sam Alexander
    last modified by Sam Alexander
  • something wrong with maven nexus repository

    I wanna integrate kettle in my java application with maven, but many dependencies in Repository - Nexus Repository Manager are unreachable and the nexus repository returns 500 status code.     I hope some...
    Wenxing Xu
    last modified by Wenxing Xu
  • i  cant SEND SNMP TRAP - get error

    Hi All,   i try to build process that will send in the end of the process SNMP trap but i get error , can someone help me to understand what i doing wrong?   i use version 8.0.0.0-28 and on my local mach...
    Nisim Rahman
    created by Nisim Rahman
  • Nombre de jours ouvrés sans les jours fériés

    Bonsoir ! Comment peut-on calculer le nombre de jours ouvrés entre deux dates en tenant compte des jours fériés dans spoon ?
    Stephane TRAORE
    last modified by Stephane TRAORE
  • Is there a way to execute the listDatabases command for MongoDB from PDI "MongoDB input"?

    I would like to iterate over all databases that are present in MongoDB and all collections in those databases. Is it possible to get a list of databases? I was trying the "MongoDB input" with dummy db and dummy collec...
    Ramon Ankersmit
    created by Ramon Ankersmit
  • Shell Step holds up Job after launching external app

    I have a Job that includes a SHELL step which launches an external application, to be used by the next step in the Job.(Runtime DB server will read a DB file and write result to file)   However, once the Shell l...
  • How to use metadata injection with Update step

    I'm using Pentaho Data Integration 8.2 CE and trying to use metadata injection to update data in table. For that I have created a transformation to get the metadata to inject, and a second transformation that contain...
    Ana Gonzalez
    last modified by Ana Gonzalez
  • Pentaho Rest API SSL is not available

    In Pentaho Rest API, I've tried using SSL config with my pfx file or jks file, but it was not useful and return 403. 1)OpenSSL is installed 2)I'm sure that the API can work because is can response with another way(a...
    redan jing
    last modified by redan jing