AnsweredAssumed Answered

Tuning Manager Agents over Firewall

Question asked by Anthony Girard Employee on Mar 18, 2014
Latest reply on Feb 26, 2015 by Anthony Girard

Hi Community,

 

we're trying to analyse a pretty strange performance problem in our environment where our oracle RAC is getting terrible response time from our AMS storage arrays, also when no load is to be seen.

 

For that we have an HCS 7.5.0-04 with Tuning Manager 7.5.0-00.

The Agent for RAID and SAN are running on our "own" admin servers without any problem because on the same network.

But the Agents running on our Oracle Servers, separated with a Firewall, are not seeing in Tuning Manager.

We want to install the agent for Platform and the agent for Oracle, but already with the first one, we're not getting anything.

 

So, I would like to ask for your help.

 

Here what we've done so far:

 

Firewall rules:

Tuning Manager Server -> Oracle Server:

Ports:

     20275/tcp (tcp_20275)

     22350/tcp (tcp_22350)

 

Oracle Server -> Tuning Manager Server

Ports:

     20272/tcp (tcp_20272)

     20273/tcp (tcp_20273)

     20274/tcp (tcp_20274)

     20275/tcp (tcp_20275)

     20276/tcp (tcp_20276)

     20289/tcp (tcp_20289)

     20290/tcp (tcp_20290)

     22285/tcp (tcp_22285)

     22350/tcp (tcp_22350)

 

Agent for Platform config on AIX/Oracle Server:

- Install agent with default parameters

- add the IP Address of our tuning manager to the hosts file

- set a route over the "right interface" to reach our htnm server according to the fw rules.

- set the name of the tuning manager server with "jpcnshostname <htnmserver>"

- disabled ipv6 "jpcnsconfig ipv6 disable"

- start all agents "jpcstart all"

 

Now checking the ports:

 

 

jpcnsconfig port list all

 

Component        ServiceID          Services        Port     Host Name

---------------- ------------------ --------------- -------- ------------------

Status Server    PT1oraserver       jp1pcstatsvr    22350    oraserver

Name Server      PN1001             jp1pcnsvr       22285    htnmserver

Action Handler   PH1oraserver       <undef>         <undef>  oraserver

Agent Store      ES1oraserver       <undef>         <undef>  oraserver

Agent Collector  EA1oraserver       <undef>         <undef>  oraserver

Agent Store      US1oraserver       <undef>         <undef>  oraserver

Agent Collector  UA1oraserver       <undef>         <undef>  oraserver

 

KAVE05916-I The service configuration information listing ended normally.

 

 

The oraserver is not showing up in the HTnM...

We were presuming that the "undef" ports could be a problem that we set them to ports we had open with the fw rules.

But still no host showing up.

(I'll add a current output of our jpcnsconfig tomorrow (my server guy is already gone today).

 

I had almost gave up, but today, looking at the Performance reporter for something else, I saw under "Agents" > UNIX an entry for the oraserver. But when I'm looking at its properties, I'm getting an error.

 

Are our FW rules not the right ones, or maybe the direction ?

Does someone knows what we really need to open and in which direction ?

 

Any help would be great.

Once the agent for AIX is working we will go on the the one for Oracle.

 

Thanks.

Anthony

Outcomes