AnsweredAssumed Answered

How to use metadata injection with Update step

Question asked by Ana Gonzalez on Apr 12, 2019
Latest reply on Jun 6, 2019 by Ana Gonzalez

I'm using Pentaho Data Integration 8.2 CE and trying to use metadata injection to update data in table.

For that I have created a transformation to get the metadata to inject, and a second transformation that contains a dummy Data Grid input step just generating one row and one column (that I don't use, but it seems it's needed for the transformation to work), and the Update step for which I'll inject the metadata, so the step is empty, it only has the connection informed:

20190412_001.bmp

The metadata for that step (target table, keys for lookup and update fields) is injected from the first transformation. When I have tried to use it, it fails saying that the field [name of the column to update] is required and couldn't be found!.

I'm attaching two transformations with a simple example, to make them work you'll have to update the connection information in the update step with something that will work for you (I have it with an Oracle connection, but I don't think that's the problem), and in that database create a table (again, this script works for Oracle, adapt to your type of database):

CREATE TABLE my_dummy_table AS
(SELECT '1' dummy_column FROM DUAL
UNION SELECT '2' dummy_column FROM DUAL);

I have tried with uppercase and lowercase for columns and table, (for some steps it doesn't matter, but for others it must be the exact syntax).

 

It's probably something stupid I haven't configured, but I can't find it.

Thanks a lot for your help

Outcomes