AnsweredAssumed Answered

Hitachi PSSnapin not working after Upgrade to 6.0.0

Question asked by Miran Kreuzer on Jun 10, 2015
Latest reply on Sep 24, 2015 by Miran Kreuzer

Hello,

 

after Upgrading Hitachi PSSnapin from 5.4.1 to 6.0.0. the Plugin is not working anymore.

 

When trying to add PSSnapin within a PS Script <add-pssnapin Hitachi.Storage.Management.Powershell.Admin>, the following Error Messages pops up:

 

add-pssnapin : The Windows PowerShell snap-in 'Hitachi.Storage.Management.Powershell.Admin' is not installed on this computer.

At line:1 char:1

+ add-pssnapin Hitachi.Storage.Management.Powershell.Admin

+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo          : InvalidArgument: (Hitachi.Storage...owershell.Admin:String) [Add-PSSnapin], PSArgumentException

    + FullyQualifiedErrorId : AddPSSnapInRead,Microsoft.PowerShell.Commands.AddPSSnapinCommand

 

 

If i try to add a Fileserver for example this Error occurs:

 

add-Fileserver : Could not load file or assembly 'HiCommon, Version=1.0.0.1, Culture=neutral, PublicKeyToken=bdc8a89dfc60b749' or one of its dependencies. The located

assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

At line:1 char:1

+ add-Fileserver -Fileserver 22.102.16.50 -Userid manager -Password nasadmin

+ ~~~~~~~~~~~~~~

    + CategoryInfo          : NotSpecified: (:) [], FileLoadException

    + FullyQualifiedErrorId : System.IO.FileLoadException

 

I have already tried to uninstall Version 6.0.0 and reinstalled 5.4.0. but the Problem still persist. Also reinstalled .netframework 4.5.

 

Regards

 

Miran

Outcomes